Old 03-20-2012, 08:38 PM   #1
Stroked68
Senior Member
 
Stroked68's Avatar
 
Join Date: Mar 2012
Location: Eudora, KS
Posts: 114
Rep Power: 6
Stroked68 is on a distinguished road
Send a message via Yahoo to Stroked68
Default 99 7.3 idle prob

For awhile now my late 99 7.3 has been acting up. It idles higher than normal. 900rpm to be exact. And the throttle is VERY touchy now too. Theres no "feathering" the throttle. Its either 900rpm or 1000 to 1200rpm. And you when you let off the throttle on the highway or just drivin 30mph it lopes really bad like its got a bad ass cam in it or somethin. Always starts right up cold, runs great on the highway. No CEL or SES lights. Had a friend pull the codes from a code reader, not an actual highdollar reader. He said it reads OBII codes for our trucks though. I've checked the EBPV sensor and pipe and they are clean. I replaced the CPS since I had a new one and no difference. I havnt checked the VC harness but the truck runs great on the highway so wouldnt think it would be that. Has over 275k on it and dont know if the injectors or GP's have been replaced. What do you guys and gals think? Its just more annoying than anything.
__________________
1999 F250 4x4 ext cab sb
DIY intake-MBRP 4" turbo back Smokers kit with dual 6" miter stacks-HPX SS crossover line-AIH delete-Fumoto valve-shimmed FPR-Recon smoked cab lights-bedliner lower 1/4-275k and counting!

1996 Cobra
1984 Ford E250 Quadravan 4x4 460 "The Tank"
1977 F250 Highboy 351m
1968 Mercury Cougar XR7 HiPo 289 "Mean Merc"
1958 Ford Panel Truck 4x4 "Grave Digger II"
2010 Kawasaki KLX250s My gas sipper
Stroked68 is offline   Reply With Quote
Old 03-20-2012, 09:18 PM   #2
westtnfx4
Senior Member
 
westtnfx4's Avatar
 
Join Date: Mar 2012
Posts: 500
Rep Power: 6
westtnfx4 is on a distinguished road
Default

I think it may be a TPS. They are bad about that. If that's not the culprit I'd say you have a intake leak possibly. Let me think on it more.....
westtnfx4 is offline   Reply With Quote
Old 03-20-2012, 09:35 PM   #3
Stroked68
Senior Member
 
Stroked68's Avatar
 
Join Date: Mar 2012
Location: Eudora, KS
Posts: 114
Rep Power: 6
Stroked68 is on a distinguished road
Send a message via Yahoo to Stroked68
Default

Originally Posted by westtnfx4 View Post
I think it may be a TPS. They are bad about that. If that's not the culprit I'd say you have a intake leak possibly. Let me think on it more.....
I was doin some readin on other forums im on and the TPS and also a Verification sensor too maybe? I know both are on the throttle pedal I think? I've checked my turbo and intake boots. Dont see anything out of the ordinary. Like i said this thing will get after it when you stomp on it and still runs great and gets decent mileage. Usually around 14 to 16.
__________________
1999 F250 4x4 ext cab sb
DIY intake-MBRP 4" turbo back Smokers kit with dual 6" miter stacks-HPX SS crossover line-AIH delete-Fumoto valve-shimmed FPR-Recon smoked cab lights-bedliner lower 1/4-275k and counting!

1996 Cobra
1984 Ford E250 Quadravan 4x4 460 "The Tank"
1977 F250 Highboy 351m
1968 Mercury Cougar XR7 HiPo 289 "Mean Merc"
1958 Ford Panel Truck 4x4 "Grave Digger II"
2010 Kawasaki KLX250s My gas sipper
Stroked68 is offline   Reply With Quote
Old 03-20-2012, 09:49 PM   #4
westtnfx4
Senior Member
 
westtnfx4's Avatar
 
Join Date: Mar 2012
Posts: 500
Rep Power: 6
westtnfx4 is on a distinguished road
Default

Do you have any small oil leaks on or around the engine? Around the HPOP?
westtnfx4 is offline   Reply With Quote
Old 03-20-2012, 10:10 PM   #5
Stroked68
Senior Member
 
Stroked68's Avatar
 
Join Date: Mar 2012
Location: Eudora, KS
Posts: 114
Rep Power: 6
Stroked68 is on a distinguished road
Send a message via Yahoo to Stroked68
Default

Originally Posted by westtnfx4 View Post
Do you have any small oil leaks on or around the engine? Around the HPOP?
No leaks. Doesnt use a drop of oil. No puddles. I mean the engine valley is somewhat damp but its always been like that.
__________________
1999 F250 4x4 ext cab sb
DIY intake-MBRP 4" turbo back Smokers kit with dual 6" miter stacks-HPX SS crossover line-AIH delete-Fumoto valve-shimmed FPR-Recon smoked cab lights-bedliner lower 1/4-275k and counting!

1996 Cobra
1984 Ford E250 Quadravan 4x4 460 "The Tank"
1977 F250 Highboy 351m
1968 Mercury Cougar XR7 HiPo 289 "Mean Merc"
1958 Ford Panel Truck 4x4 "Grave Digger II"
2010 Kawasaki KLX250s My gas sipper
Stroked68 is offline   Reply With Quote
Old 04-06-2012, 12:36 AM   #6
Stroked68
Senior Member
 
Stroked68's Avatar
 
Join Date: Mar 2012
Location: Eudora, KS
Posts: 114
Rep Power: 6
Stroked68 is on a distinguished road
Send a message via Yahoo to Stroked68
Default

Ok did some reading on the net and im hearin more about the ICP and IPR. I checked my ICP connector and it was full of oil so the sensor is bad. I cleaned it and it seemed to fix it for now. Can I just leave it disconnected or is there a mod you can do to take it out of the system? Also seems the IPR needs cleaned every now and then? Some start to get gunked up and stick. Anyone ever rebuild one?
__________________
1999 F250 4x4 ext cab sb
DIY intake-MBRP 4" turbo back Smokers kit with dual 6" miter stacks-HPX SS crossover line-AIH delete-Fumoto valve-shimmed FPR-Recon smoked cab lights-bedliner lower 1/4-275k and counting!

1996 Cobra
1984 Ford E250 Quadravan 4x4 460 "The Tank"
1977 F250 Highboy 351m
1968 Mercury Cougar XR7 HiPo 289 "Mean Merc"
1958 Ford Panel Truck 4x4 "Grave Digger II"
2010 Kawasaki KLX250s My gas sipper
Stroked68 is offline   Reply With Quote
Old 02-06-2016, 04:24 PM   #7
hunt
Junior Member
 
Join Date: Feb 2016
Age: 29
Posts: 7
Rep Power: 0
hunt is on a distinguished road
Default

I was looking for this information. Thanks a lot guys!
__________________
192.168.1.1
hunt is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump